Archive for the Uncategorized Category

Oracle’s VirtualBox + Windows 8 Consumer Preview + Visual Studio 11 Ultimate Beta = FAIL? (Updated with a fix!)

Posted in Uncategorized on March 2, 2012 by juarola

Hello all,

i’ve been trying to set up the title’s combo with no success so far. Everything works real smooth until trying to fire up Visual Studio’s installer. I get the gray “Visual Studio 11 Beta”-splash screen and then FAIL with: Continue reading

Unit testing Windows Phone 7 MvvmLight-viewmodels with 7.1 sdk rc, NUnit and Moq

Posted in Uncategorized on September 6, 2011 by juarola

After a few hours of banging my head againt the wall, i finally bended this combo to my will. Humble thanks to J. Wilcox, J. Cansdale, W. McClure. Even humbler thank you goes to rschiefer for tipping me towards the version of Moq that worked in this scenario!

Continue reading

Windows Phone 7 – Vote for better mocking framework support

Posted in Uncategorized on September 6, 2011 by juarola

If you’re developing for WP7 – please go and vote here!

Problems connecting Visual Studio 2008 to TFS 2010

Posted in Uncategorized on July 3, 2011 by juarola

Today i faced some problems while trying to connect VS2008 to TFS2010. Illegal characters in TFS-server’s uri, TF253022 FCU not installing properly and what not…

Continue reading

Windows Phone 7.1 “Mango” – HIC SVNT DRACONES (Charting the Application Lifecycle)

Posted in Uncategorized on July 1, 2011 by juarola

I’ll be I might be I won’t have the time to be using this post to make notes about Mango lifecycle. Few hurdles so far, nothing too serious…

Here’s an flowchart (-ish) image with my initial understanding of the model. I’ll be I might I won’t have the time to be updating this with hints etc. All notes are in finnish for now, but i can translate them if someone is interested.

Lifecycle, second attempt

Continue reading

Windows Phone 7.1 “Mango” – deployment to device fails with error “0x81030120”

Posted in Uncategorized on June 30, 2011 by juarola

Another really descriptive error message. I couldn’t find anything useful from regular sources, but then Akira Onishi provided me with the answer.

Just comment out the following line from WMAppManifest.xml:

<Capability Name="ID_CAP_INTEROPSERVICES" />

Windows Phone 7 – one fix for “Xap packaging failed. Object reference not set to an instance of an object.”

Posted in Uncategorized on June 28, 2011 by juarola

I faced that error while building a WP7 app after doing some reorganization of files within the solution.

VS2010 didn’t give any pointers, so i turned to Google and found this post in Jayway Team’s blog. My problem was not exactly the same, but that post pointed me to the right direction. Thank you to Jayway Team!

I had accidentally moved the default “ApplicationIcon.png” and “BackGround.png” from the root of the solution to a resources folder. After a bit of digging around the solution, i found the references to those images in the WMAppManifest.xml-file located within properties folder.

Issue went away by altering the paths. Really simple, but why-oh-why VS couldn’t give me any useful information right at the beginning…